Integrating with SmartThings

Follow

Comments

21 comments

  • Avatar
    Greg Powers

    This is a very cumbersome procedure  to add the Gear to SmartThings. I can not believe your are forcing us to go through the "developer interface" to add a device to SmartThings. 

    Adding the Axis Gear should be a straight forward as add a Ecobee thermostat, Halo smoke detector or a Wifi Switch. Requiring the user to got to Gethub and then the SmartThings developer environment is just nuts.

    When will the Gear be added to the list of Devices "Inside SmartThing" making it simple and straight forward to add the Gear to SmartThings?.   

  • Avatar
    Josephjlee777

    I tried following the directions and have installed my own device handlers with other devices, but the Axis 

    devicetypes/axis/axis-gear.src/axis-gear.groovy is not showing up in the SmartThingsPublic (master) repo.

  • Avatar
    John Davenport

    Agree - this process is ridiculous and should be much easier. Disappointed so far with product integration capabilities

  • Avatar
    Alison A Martinez

    I'm having the same problem as Josephjlee777.

  • Avatar
    Kip

    I'm in the API.smartthings.com but when i'm in the simulator panel to config i ran into an issue. Under "Devices" i have it set to Virtual and when specifying "Physical Devices" my Axis Gear doesn't show up? This is done via an ipad on the same wifi with the Samsung smartthings APP installed..... any idea's why my gear doesn't show up?? Sucks that i'm stuck on the last step and now stuck!  

  • Avatar
    Antonio Romero

    Hello, 

    I did the steps and it worked, at least for the first one, I need to try with the rest of them, but do I need to use the classic app in order to make this work? can it be the other Smartthings app? I see the Axis on the classic, but not in the latest ST app.

     

  • Avatar
    Manu | AXIS

    Kip - Not sure if you saw this - we updated the SmartThings integration process last week. From your post, I would recommend that you repeat Steps 5 & 6 every time you log into the http://developer.smartthings.com/ If you are still facing issues, please reach out to us using this link 

    Antonio - Great to hear it's working for you. You would need to use the Smartthings Classic app in order for the integration to work.

    Hope this helps!

    AXIS Team

  • Avatar
    Ryan Wong

    I've followed the instructions. It's pretty straight forward and the tutorial is bang on. Only problem - after i've updated and the Axis shows up in the Smarthings app, I still can't control it. I've tried clicking the on/off buttons and nothing seems to trigger an action. I have my axis gear set to "smart home mode", and it's fully charged. Help?

  • Avatar
    Jami | AXIS

    Hi Ryan,

    That sounds very strange. Please be advised, Axis Gear is only compatible with the SmartThings Classic App* found in your mobile device's app storeAre you using a different app? If you are still facing issues, please reach out to us using this link

  • Avatar
    Ryan Wong

    Jami - I'm using SmartThings Classic. Followed all the instructions. The Axis Gear is showing up on my app...just doesn't do anything when I click any of the buttons.

    Does it have anything to do with the fact that I am on the iOS beta? I am using 12.1.1 iOS vs. the mass market version of 12.1.

  • Avatar
    Kip

    Ryan Wong and i have the same issue, it shows up in Smart Things (Classic) but will not respond to anything. I copied the TXT file via the API ST site and everything looks ok but it's not working??

  • Avatar
    Kip

    I’m in the Smart Things API (simulator) and call out “Alex, close the shades” I see the simulator window on the right hand side go from open to close. The bottom line is when giving it voice commands or APP commands the physical unit is not responding. If I physically touch the unit to open and close it, it does work. I pulled a log file from the API ST site. Who at Axis should I send it to?

     

  • Avatar
    Jami | AXIS

    Hi,

    Please try these steps:

    1. Go to the location

    2. Select hub, and click on your devices 

    3. Verify if the type says Axis Gear-v3 

    4. Press the pair button and see if it blinks green to verify if it's still on the network

  • Avatar
    Kip

    i paired it again, the green light flashes, but via the API.smartthings.com it indicates the unit is offline. ...? Also i'm running the Axis Gear-v3. 

     

  • Avatar
    Ryan Wong

    Jami - I followed the steps and double checked. It's now showing Purple when I click the "pair" button. 

    Still not working, but shows up in the Smartthings Classic app

  • Avatar
    Daniel Paiva

    Same here. Lights are purple. Shows up on the classic ST app but doesn’t work at all.

  • Avatar
    Peter L

    holy, this process is pretty terrible . Went and bought a smart things hub to find I have to go to developer mode to set up..  Is this going to be changed at some point?  This is total a bait and switch move. 

     

    I have to install with axis gear app first, then do smart things config.  What happens if I need to do a slight adjustment because rollershade settings are off. needs to do a total hard reset and go through the whole process again?

  • Avatar
    Peter L

    also how do i update to latest firmware if I can no longer connect through axis app..

  • Avatar
    Ryan Wong

    Hey Axis Team, I think I can speak on behalf of many of the users on this thread, the product isn't working as described. Can I ask that you post a link to a video showing us the step by step? No editing required...just a raw video end-to-end including the process on screen of how to input the code into SmartThings' web portal and the corresponding functional blind via voice control so we can start to break down what we're doing wrong here?

    Thanks

  • Avatar
    pradeep

    Agreed with Ryan above. Just bought a Samsung SmartThings hub, followed the process above, everything shows online and "working", but device won't accept any commands from the app. Physical device touch controls work to move shade up and down, but commands from SmartThings Classic app don't do anything on device. Also, when I hit pair, the device lights up Purple, not green. 

    Please let us know what we should be doing to fix it. As Ryan said, a video would be worth a thousand forum replies. Please and thank you. 

    Below is screenshot from my Samsung Dev account showing Axis as Active on the home Hub. 

  • Avatar
    Zach Gloer

    This isn’t working.. I waited like over half a year to finally get this thing and all I can do is manually make it move my blinds by walking over to it and touching it? I did the whole work around as described above and it shows up in my Smart Things Classic app yet doesn’t control it. Where can I send this back for a refund?

Please sign in to leave a comment.